Shortcut not working?

Mar 6, 2014 at 8:36 PM
I installed this extension to go with SSMS 2012, and the shortcut doesn't appear to work. I have it configured within Tools > Options > Keyboard as ctrl+shift+e (global) and it's still not working. I tried adding it to several other areas like SQL query editor, etc. but nothing seemed to work. What am I doing wrong?
Apr 14, 2014 at 5:44 AM
Edited Apr 14, 2014 at 6:05 AM
I am facing the same issue. I downloaded the add-in yesterday. I'm wondering if it's a bug with the add-in. Maybe the shortcut is working but the add-in isn't doing anything.

UPDATE: I uninstalled the latest version and installed the previous version 1.0.2 and it seems to be working fine. Also I've noticed that the add-in won't work if there is a parse error anywhere in the query file regardless of whether that is part of the current statement or not.
Apr 17, 2014 at 7:33 PM
Tried installing 1.0.2 like you said and that version works.

Seems 1.0.3 is busted.
Coordinator
May 29, 2014 at 8:59 AM
Edited May 29, 2014 at 9:02 AM
Hi gays, thanks for the feedback.
Unfortunately I can't reproduce the described issue (tested with both 32/64bit Windows 7/8).

Do you have any other add-ins that have command with the same shortcut combination (for example SQL Complete from DevArt). The shortcut should be set under SQL Query Editor.

Regrades that the add-in won't work if there is a parse error anywhere in the script, this is exactly the change in version 1.0.3

The add-in is also adding a command button in the Standard Toolbar. Can you confirm the button exists in version 1.0.3. Does the current statement executes when clicked?

Image
Sep 14, 2014 at 12:37 PM
Sorry for taking so long to get back to you. I uninstalled 1.0.2 and reinstalled 1.0.3 and it's still not working. Basically when I execute the shortcut combination (ctrl + shift + E) nothing happens. The command button does exist. When I click it still nothing happens. Very curious.

Image

I'm using Microsoft SQL Server Management Studio v11.0.3000.0 (I believe comes with SQL Server 2012) on Windows 7 Enterprise x64.

OK just tried to play around with it again now just to confirm before i send the message... it seems that the shortcut and/or command button work when I highlight the statement text that I want executed. Otherwise it won't do anything.

Image

Hope this helps you. Good luck.
Dec 10, 2014 at 9:43 AM
Edited Dec 10, 2014 at 9:45 AM
same here, button exists, neither it or any attached shortcut works as expected

command is executed only if there is a block selected... just as if F5 was hit

I'll try 1.0.2 then

__

Just one more comment.

As I need to use separate admin account for installing stuff like this. It does not work after installation for any other user, which is a bit of pain. What I had to do is basically copy the addin file from my admin user to the other users.
Would be nice if installator had an option to install for all users. Or if plugin came as a separate addin file :)
Coordinator
May 11, 2015 at 9:01 AM
Hello all, thank you for the feedback.
I finally found the issue. There were missing dll dependencies that I've excluded from the setup project.
Please download release v1.0.3-1. The issues is corrected.

Please let me know if this works for you.
Thank you.